Windows Live Writer and WordPress Image Uploads

imageOk – not exactly the first post I wanted to put up – but I’ve spent the better part of an evening with @energizedTech helping me figure out why I have been unable to easily upload blog posts with images imbedded in them written by LiveWriter. I was leaving the default options of using the RPC connectivity to upload the files correctly into the Media library on the WP blog – nothing was working if the image pixels were over 300 x whatever – it just failed!

Web interface was no help either – I’d go into media libraries, manually upload a larger file (600 x 399 as an example) and it would error out on me after uploading with a simple red HTTP Error – seeming to fail.  But – with a refresh of the library contents – low and behold – the file would be there! To include it into a post – it would be a manual edit/add into a post to include the picture from the media library and finally – the thing would be done.

not exactly your easiest fix to get this working. Kinda stupid really. Got any ideas – I am all ears!

My work around for now? Using the FTP upload option properly configured to my particular hosting provider (1 and 1) and blog location.

image

Rockin’ it old school – just for some screenshots and simple image uploads! Thanks LiveWriter for having some flexibility on image storage options.

About author View all posts

Rick


Warning: sizeof(): Parameter must be an array or an object that implements Countable in D:\home\site\wwwroot\wp-content\plugins\projectnami-blob-cache\project-nami-blob-cache.php on line 416

Fatal error: Uncaught WindowsAzure\Common\ServiceException: Fail: Code: 400 Value: The account being accessed does not support http. details (if any): <?xml version="1.0" encoding="utf-8"?><Error><Code>AccountRequiresHttps</Code><Message>The account being accessed does not support http. RequestId:b5727fc6-c01e-0068-50e3-ea961e000000 Time:2020-02-24T07:26:34.5127953Z</Message><AccountName>ritgcache</AccountName></Error>. in D:\home\site\wwwroot\wp-content\plugins\projectnami-blob-cache\library\WindowsAzure\Common\Internal\Http\HttpClient.php:382 Stack trace: #0 D:\home\site\wwwroot\wp-content\plugins\projectnami-blob-cache\library\WindowsAzure\Common\Internal\Http\HttpClient.php(275): WindowsAzure\Common\Internal\Http\HttpClient::throwIfError(400, 'The account bei...', '\xEF\xBB\xBF<?xml versio...', Array) #1 D:\home\site\wwwroot\wp-content\plugins\projectnami-blob-cache\library\WindowsAzure\Common\Internal\RestProxy.php(141): WindowsAzure\Common\Internal\Http\HttpClient->send(Array, Object(WindowsAzure\Common\Internal\ in D:\home\site\wwwroot\wp-content\plugins\projectnami-blob-cache\library\WindowsAzure\Common\Internal\Http\HttpClient.php on line 382